VM's policies are too old to be run by this version

23. January 2013 20:46 by Mrojas in   //  Tags: , , , , , , , ,   //   Comments (0)

I don't know why but I took one virtual machine from my computer to a clients office and when I tried to open it with VMware 9 I started getting a strange error: "VM's policies are too old to be run by this version"

What was that?

Well, I don't know yet, but my workaround was:


1. Go to the directory with the Virtual Machine files

2. Find <vm>.vmpl file and rename it to donotuse <vm>.vmpl

3. Double click the <vm>.vmx file

4. It will fail indicating that a file was not found

5. Open the <vm>.vmx file with notepad.exe. Look for something like:

policy.vm.mvmtid = "52 32 e7 62 63 ea 0d 0d-3a 55 cd 4c 11 69 ee e6"
policy.vm.managedVMTemplate = "FALSE"
policy.vm.managedVM = "FALSE"

Erase those three lines.

5. Save the file

6. And voila I was now able to open my virtual machine :)